Error Message (SessionManager) in WP 4.7 WC 3.X

Home Forums Support Error Message (SessionManager) in WP 4.7 WC 3.X

This topic contains 4 replies, has 2 voices, and was last updated by Sean P Sean Powell 1 year, 6 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #11240
    Daniel F
    Daniel Frye
    Participant

    Hello, I am having an issue with the plug-in. I am using WordPress 4.7.5 running Kale theme.

    This is the error message I am receiving

    Warning: Declaration of MyStyle_SessionManager::persist(MyStyle_Session $session) should be compatible with MyStyle_EntityManager::persist(MyStyle_Entity $entity) in /home3/printnj/public_html/ltbproducts.com/wp-content/plugins/mystyle-custom-product-designer/includes/entities/class-mystyle-sessionmanager.php on line 157

    #11242
    Sean P
    Sean Powell
    Keymaster

    Hello,

    We have a patch for this issue, which is caused by the updates from WooCommerce 3.x+ and/or PHP 7+.

    Please press “update” on your MyStyle Plugin and make sure you are on version 2.0.0, as this version starts supporting WooCommerce 3.x+

    Thanks,

    – Sean

    #11253
    Sean P
    Sean Powell
    Keymaster
    #11254
    Daniel F
    Daniel Frye
    Participant

    Thank you Sean, Just updated the plug-in and works perfect!

    #11259
    Sean P
    Sean Powell
    Keymaster

    Awesome Daniel, glad to hear it.

    Closing this ticket as resolved!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Error Message (SessionManager) in WP 4.7 WC 3.X’ is closed to new replies.

Personalization and Customization Platform