Browser Compatibility

Home Forums Support Browser Compatibility

This topic contains 5 replies, has 2 voices, and was last updated by Sean P Sean Powell 1 year, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #11224
    Gordon M
    Gordon McCombe
    Participant

    Is there a known compatibility issue with the plugin on different browsers.

    I have the plugin working after an earlier issue with Woo Commerce but I can only get it to work on MS Explorer. I would have thought MS Explorer was the last one it would have worked on!!

    Selecting “Customize” on my product page in Chrome, Safari or MS Edge does not show the customizer interface. I have tried the HTML5 check box (even though it is advised not to) but still all this does is give a simpler interface on MS Explorer, nothing on the others.

    Regards,

    Gordon

    #11225
    Sean P
    Sean Powell
    Keymaster

    Hi Gordon,

    Different browsers handle both Flash and SSL slightly differently, but if you have the HTML5-Only checkbox ticked in your settings, you can at least be sure the Flash handling is not the cross-browser inconsitency that you’re seeing.

    The HTML5 app is not just a different UI, it’s also responsive and mobile compatible for all devices. The other UI runs on the Flash plugin, which is largely blocked by most browsers now that Chrome changed their default settings to block it in March (it can be turned on in settings but that’s not realistic for most users).

    If the HTML5 app has everything you want, you may want to go with that only to be more consistent with all users.

    Also, the html5 version is now SSL compatible as of yesterday!

    Have you tried temporarily disabling all plugins except mystyle to test? That will tell you if it’s another plugin that is causing a conflict. By process of elimination you can find which plugin causes it and we could try to investigate it.

    #11226
    Sean P
    Sean Powell
    Keymaster

    Hi Gordon,

    Yeah I can see you’re using SSL on your /customize/ page. That’s most likely the issue.

    Our next plugin release next week will have SSL support for HTML5 as well, but right now your pre-release is writing the iframe URL with http://.

    Until then- temporary solutions:

    1) Can you exclude that page from SSL so it’s regular http:// instead of https:// ?

    I think there are some plugins that let you manage SSL on some pages and not others if you’re not able to do it via PHP or .htaccess yourself

    2) Edit some php… (hacky)
    If you are able to change the line that writes the iframe URL and replace http:// with https:// it would work.

    3) Turn off full-site SSL and just use SSL for checkout (woocommerce setting)

    #11239
    Sean P
    Sean Powell
    Keymaster

    Hi Gordon,

    Just an update that we’re working on the remaining SSL support items and then will be releasing our main plugin with 2.0.1 or higher later this week.

    Until then you should be able to test if you can turn off SSL on your dev site.

    Thanks,

    – Sean

    #11260
    Sean P
    Sean Powell
    Keymaster

    Hi Gordon,

    MyStyle’s main plugin and all add-ons for it are now up to date, here’s the info:

    Major Release (2.0.0) for WooCommerce 3.X / PHP 7.X – All MyStyle WordPress Plugins and Add-Ons

    #11281
    Sean P
    Sean Powell
    Keymaster

    Hi Gordon,

    We released 2.0.1 today for our main plugin and our add-ons for WP.

    Please be sure to update to 2.0.1 to squash potential bugs that may occur with the older versions.

    Thanks,

    – Sean

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Browser Compatibility’ is closed to new replies.

Personalization and Customization Platform