Woo Commerce Plugins

Major Release (2.0.0) for WooCommerce 3.X / PHP 7.X – All MyStyle WordPress Plugins and Add-Ons

UPDATE 5/31/2017: We have released 2.0.1 which patches some issues being caused by the plugin/add-on load order which we have no control over. In my dev environment, the design manager was loading second and then it worked. In v2.0.1 (of all of our add-ons) I updated the code so that it will work regardless of the plugin load order.
Original Post Below:


Today we released a highly anticipated update for the MyStyle Custom Product Designer plugin and all its related MyStyle add-ons that make them compatible with numerous 3rd party technology updates including:

  • WooCommerce 2.X
  • WooCommerce 3.X
  • WordPress 4.7.X (tested up to 4.7.5 5/30/2017)
  • PHP 5.X
  • PHP 6.X
  • PHP 7.X

Major Version 2.0 Across All Plugins

To keep things in sync we’ve updated to major revision number 2.0.0 for our main WordPress plugin (MyStyle Custom Product Designer).  This is a distinct change to many of the hooks and programming methods that were previously used in WooCommerce 2.X.

This includes:

  • MyStyle Custom Product Designer
  • Design Manager add-on
  • Email Manager add-on
  • Order Queue add-on

This means any MyStyle plugin with version 2.0 or higher will be compatible with the current WooCommerce version (3.0.7) or older, and will most likely stay compatible with WooCommerce’s upcoming minor revisions and updates since their 3.X changes were also a major update that cleaned and refactored significant internal core programming and should last them years with their new structure.

Dev Notes

Here’s a few words on things to note from our senior WP developer:

v2.0.0 of the plugins supports WooCommerce 3.0.x and PHP 7.0.x. They are backwards compatible and still support WooCommerce 2.x.x and PHP 5.3-6. Since the main plugin is backwards compatible with the old versions of the add-ons, older versions of php and WooCommerce 2.x, everyone should be able to upgrade all of our MyStyle add-on plugins without issues. It should be noted however, that the change-variations-in-cart plugin and product add-ons plugin aren’t yet compatible with WC 3.x or PHP 7. So sites using these plugins should stay on WC 2.x and PHP 5.x for now. It should also be noted that many other plugins from other companies don’t yet support WC 3.x and PHP 7, so updating even when not running the above two plugins should be done with care.
 

SSL Support

The HTML5 app now supports SSL out of the box in BETA form. If you are in need of an https:// (SSL) solution for your website, use the checkbox to force HTML5 only to test out SSL support!

Update Your Site if Using WooCommerce 3.X

Be sure to update your site plugins accordingly if you’re using WooCommerce 3.X or higher.